import re
regex = re.compile(r"(?P<dd>\d{1,2})(?P<sep>[\/.-]{1})(?P<mm>\d{1,2})(?P=sep)(?P<yy>\d{2,4})", flags=re.IGNORECASE)
test_str = ("data: 12/11/2011 \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")