re = /(?P<dd>\d{1,2})(?P<sep>[\/.-]{1})(?P<mm>\d{1,2})(?P=sep)(?P<yy>\d{2,4})/i
str = 'data: 12/11/2011
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end