import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\b[A-Z])[.\\s]+(?=[A-Z]\\b)|(?<=\\b[A-Z])\\.(?=\\s[A-Z])";
final String string = "J R R Tolkien\n"
+ "E L James\n"
+ "F Scott Fitzgerald\n\n"
+ "JK Rowling\n"
+ "J.K. Rowling\n"
+ "J. K. Rowling\n"
+ "J K Rowling\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}