re = /(?<=\b[A-Z])[.\s]+(?=[A-Z]\b)|(?<=\b[A-Z])\.(?=\s[A-Z])/
str = 'J R R Tolkien
E L James
F Scott Fitzgerald
JK Rowling
J.K. Rowling
J. K. Rowling
J K Rowling
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result