$re = '/(?<=\b[A-Z])[.\s]+(?=[A-Z]\b)|(?<=\b[A-Z])\.(?=\s[A-Z])/';
$str = 'J R R Tolkien
E L James
F Scott Fitzgerald
JK Rowling
J.K. Rowling
J. K. Rowling
J K Rowling
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;