const regex = new RegExp('(?<=\\b[A-Z])[.\\s]+(?=[A-Z]\\b)|(?<=\\b[A-Z])\\.(?=\\s[A-Z])', 'g')
const str = `J R R Tolkien
E L James
F Scott Fitzgerald
JK Rowling
J.K. Rowling
J. K. Rowling
J K Rowling
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);