$re = '/^(?=(?:.*[a-z]){2})(?:(?!^[\W_]|[\W_]{2}|[\W_]$)[\w.]){3,25}$/mi';
$str = 'A.s
0as
a.a
a.0
0.0
a._a
a.0a
1rockit.man
q3w
e4.45r.d.2
sp_am
.ret.
123
12a
ret..wer
super_.duper
_petrat
petrat_
aa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);