import re
regex = re.compile(r"^(?=(?:.*[a-z]){2})(?:(?!^[\W_]|[\W_]{2}|[\W_]$)[\w.]){3,25}$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("A.s\n"
"0as\n"
"a.a\n"
"a.0\n"
"0.0\n"
"a._a\n"
"a.0a\n"
"1rockit.man\n"
"q3w\n"
"e4.45r.d.2\n"
"sp_am\n"
".ret.\n"
"123\n"
"12a\n"
"ret..wer\n"
"super_.duper\n"
"_petrat\n"
"petrat_\n"
"aa\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")