use strict;
my $str = 'select id, :DATA_INI, \':DATA_INI\', titulo,
date_format(data_criacao,\'%d/%m/%Y %H:%i\') str_data_criacao
from v$sugestoes
where data_criacao between :DATA_INI AND :DATA_FIM AND \':TEST\'
and \'test \'\'string :DATA_INI \'\' :DATA_INI \'
order by data_criacao';
my $regex = qr/:(?=([^']*'[^']*')*[^']*$)/p;
my $subst = '@';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";