import re
regex = re.compile(r":(?=([^']*'[^']*')*[^']*$)")
test_str = ("select id, :DATA_INI, ':DATA_INI', titulo, \n"
"date_format(data_criacao,'%d/%m/%Y %H:%i') str_data_criacao\n"
"from v$sugestoes\n"
"where data_criacao between :DATA_INI AND :DATA_FIM AND ':TEST'\n"
"and 'test ''string :DATA_INI '' :DATA_INI '\n"
"order by data_criacao")
subst = "@"
result = regex.sub(subst, test_str)
if result:
print(result)