re = /:(?=([^']*'[^']*')*[^']*$)/
str = 'select id, :DATA_INI, \':DATA_INI\', titulo,
date_format(data_criacao,\'%d/%m/%Y %H:%i\') str_data_criacao
from v$sugestoes
where data_criacao between :DATA_INI AND :DATA_FIM AND \':TEST\'
and \'test \'\'string :DATA_INI \'\' :DATA_INI \'
order by data_criacao'
subst = '@'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result