import Foundation
let pattern = #":(?=([^']*'[^']*')*[^']*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
select id, :DATA_INI, ':DATA_INI', titulo,
date_format(data_criacao,'%d/%m/%Y %H:%i') str_data_criacao
from v$sugestoes
where data_criacao between :DATA_INI AND :DATA_FIM AND ':TEST'
and 'test ''string :DATA_INI '' :DATA_INI '
order by data_criacao
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"@"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)