const regex = /^(?=(?:\D*\d){3}\D*$)(?:[a-z\d]*[A-Z]){2}[a-z\d]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:\\D*\\d){3}\\D*$)(?:[a-z\\d]*[A-Z]){2}[a-z\\d]*$', 'gm')
const str = `HelLo1aa2s3d
WindowA1k2j3
Window A1 k2j3
AAAsjs21js1
ASaaak12
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}