use strict;
my $str = 'HelLo1aa2s3d
WindowA1k2j3
Window A1 k2j3
AAAsjs21js1
ASaaak12
';
my $regex = qr/^(?=(?:\D*\d){3}\D*$)(?:[a-z\d]*[A-Z]){2}[a-z\d]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}