import re
regex = re.compile(r"^(?=(?:\D*\d){3}\D*$)(?:[a-z\d]*[A-Z]){2}[a-z\d]*$", flags=re.MULTILINE)
test_str = ("HelLo1aa2s3d\n"
"WindowA1k2j3\n"
"Window A1 k2j3\n"
"AAAsjs21js1\n"
"ASaaak12\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")