re = /^(?=(?:\D*\d){3}\D*$)(?:[a-z\d]*[A-Z]){2}[a-z\d]*$/m
str = 'HelLo1aa2s3d
WindowA1k2j3
Window A1 k2j3
AAAsjs21js1
ASaaak12
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end