package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^,]+,\s*)\b(https?:\/\/.*?)(\s*,[^,]+)$`)
var str = `Something,https://stackoverflow.com/questions/ask/,Anotherthing
Something,https://stackoverflow.com/questions/ask,Anotherthing
link:https://www.google.com/something,something else
http://www.domain.com/without-ssl
Something followed by a space, https://domain.com, more to come
Now I can have commas in the path, http://test.com/?pages=1,2,3, more stuff...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}