import re
regex = re.compile(r"^([^,]+,\s*)\b(https?:\/\/.*?)(\s*,[^,]+)$", flags=re.MULTILINE)
test_str = ("Something,https://stackoverflow.com/questions/ask/,Anotherthing\n"
"Something,https://stackoverflow.com/questions/ask,Anotherthing\n"
"link:https://www.google.com/something,something else\n"
"http://www.domain.com/without-ssl\n"
"Something followed by a space, https://domain.com, more to come\n"
"Now I can have commas in the path, http://test.com/?pages=1,2,3, more stuff...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")