$re = '/^([^,]+,\s*)\b(https?:\/\/.*?)(\s*,[^,]+)$/m';
$str = 'Something,https://stackoverflow.com/questions/ask/,Anotherthing
Something,https://stackoverflow.com/questions/ask,Anotherthing
link:https://www.google.com/something,something else
http://www.domain.com/without-ssl
Something followed by a space, https://domain.com, more to come
Now I can have commas in the path, http://test.com/?pages=1,2,3, more stuff...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);