use strict;
my $str = 'Something,https://stackoverflow.com/questions/ask/,Anotherthing
Something,https://stackoverflow.com/questions/ask,Anotherthing
link:https://www.google.com/something,something else
http://www.domain.com/without-ssl
Something followed by a space, https://domain.com, more to come
Now I can have commas in the path, http://test.com/?pages=1,2,3, more stuff...';
my $regex = qr/^([^,]+,\s*)\b(https?:\/\/.*?)(\s*,[^,]+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}