#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^Total revenue for )(?=\d+[-_]?\d+)[\d_-]{6,7}(?!\S)"
Local $sString = "Total revenue for 2016-03 is 3000 €" & @CRLF & _
"Total revenue for 2016_03 is 3000 €" & @CRLF & _
"Total revenue for 201603 is 3000 € " & @CRLF & _
"" & @CRLF & _
"Total revenue for 2016-03 is 3000 €" & @CRLF & _
"Total revenue for 2016_03 is 3000 €" & @CRLF & _
"Total revenue for 201603 is 3000 €" & @CRLF & _
"Total revenue for 032016 is 3000 €" & @CRLF & _
"Total revenue for 03_2016 is 3000 €" & @CRLF & _
"Total revenue for 03-2016 is 3000 €" & @CRLF & _
"Total revenue for 3000 is 3000 €" & @CRLF & _
"Total revenue for 30-00100-1010101 is 3000 €" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")