# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=^Total revenue for )(?=\d+[-_]?\d+)[\d_-]{6,7}(?!\S)"
test_str = ("Total revenue for 2016-03 is 3000 €\n"
"Total revenue for 2016_03 is 3000 €\n"
"Total revenue for 201603 is 3000 € \n\n"
"Total revenue for 2016-03 is 3000 €\n"
"Total revenue for 2016_03 is 3000 €\n"
"Total revenue for 201603 is 3000 €\n"
"Total revenue for 032016 is 3000 €\n"
"Total revenue for 03_2016 is 3000 €\n"
"Total revenue for 03-2016 is 3000 €\n"
"Total revenue for 3000 is 3000 €\n"
"Total revenue for 30-00100-1010101 is 3000 €\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.