using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^Total revenue for )(?=\d+[-_]?\d+)[\d_-]{6,7}(?!\S)";
string input = @"Total revenue for 2016-03 is 3000 €
Total revenue for 2016_03 is 3000 €
Total revenue for 201603 is 3000 €
Total revenue for 2016-03 is 3000 €
Total revenue for 2016_03 is 3000 €
Total revenue for 201603 is 3000 €
Total revenue for 032016 is 3000 €
Total revenue for 03_2016 is 3000 €
Total revenue for 03-2016 is 3000 €
Total revenue for 3000 is 3000 €
Total revenue for 30-00100-1010101 is 3000 €
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}