re = /(?<=^Total revenue for )(?=\d+[-_]?\d+)[\d_-]{6,7}(?!\S)/m
str = 'Total revenue for 2016-03 is 3000 €
Total revenue for 2016_03 is 3000 €
Total revenue for 201603 is 3000 €
Total revenue for 2016-03 is 3000 €
Total revenue for 2016_03 is 3000 €
Total revenue for 201603 is 3000 €
Total revenue for 032016 is 3000 €
Total revenue for 03_2016 is 3000 €
Total revenue for 03-2016 is 3000 €
Total revenue for 3000 is 3000 €
Total revenue for 30-00100-1010101 is 3000 €
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end