using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(\w+\[[^]]+\]:'(?:''|[^'])+')$";
string input = @"id[varchar]:'текст1 текст2' col_2[varchar]:'текст1 текст2' col_3[varchar]:'текст1 ''текст'' текст2'";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}