$re = '/\s(\w+\[[^]]+\]:\'(?:\'\'|[^\'])+\')$/i';
$str = 'id[varchar]:\'текст1 текст2\' col_2[varchar]:\'текст1 текст2\' col_3[varchar]:\'текст1 \'\'текст\'\' текст2\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);