package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\s(\w+\[[^]]+\]:'(?:''|[^'])+')$`)
var str = `id[varchar]:'текст1 текст2' col_2[varchar]:'текст1 текст2' col_3[varchar]:'текст1 ''текст'' текст2'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}