re = /\s(\w+\[[^]]+\]:'(?:''|[^'])+')$/i
str = 'id[varchar]:\'текст1 текст2\' col_2[varchar]:\'текст1 текст2\' col_3[varchar]:\'текст1 \'\'текст\'\' текст2\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end