package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<bundlePath>.*?\/(?P<bundleName>[^\/]+\.bundle))`)
var str = `/System/Library/CoreServices/AOS.bundle/Contents/version.plist
/System/Library/CoreServices/Br.bundle/Contents/Resources/brtool
/System/Library/CoreServices/backupd.bundle/Contents/PlugIns/brtools.bundles/Contents/Version.plist`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}