import re
regex = re.compile(r"^(?P<bundlePath>.*?\/(?P<bundleName>[^\/]+\.bundle))", flags=re.MULTILINE)
test_str = ("/System/Library/CoreServices/AOS.bundle/Contents/version.plist\n"
"/System/Library/CoreServices/Br.bundle/Contents/Resources/brtool \n"
"/System/Library/CoreServices/backupd.bundle/Contents/PlugIns/brtools.bundles/Contents/Version.plist")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")