re = /^(?P<bundlePath>.*?\/(?P<bundleName>[^\/]+\.bundle))/m
str = '/System/Library/CoreServices/AOS.bundle/Contents/version.plist
/System/Library/CoreServices/Br.bundle/Contents/Resources/brtool
/System/Library/CoreServices/backupd.bundle/Contents/PlugIns/brtools.bundles/Contents/Version.plist'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end