import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<bundlePath>.*?\\/(?P<bundleName>[^\\/]+\\.bundle))";
final String string = "/System/Library/CoreServices/AOS.bundle/Contents/version.plist\n"
+ "/System/Library/CoreServices/Br.bundle/Contents/Resources/brtool \n"
+ "/System/Library/CoreServices/backupd.bundle/Contents/PlugIns/brtools.bundles/Contents/Version.plist";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}