$re = '/(G{2,5})([ACGT]{1,7})\1([ACGT]{1,7})\1([ACGT]{1,7})\1/';
$str = 'GGAAAGGAAGGAAGG
GGAAAGGAAGGGAAGG
^ OK because [ACGT]
GGAAAGGAAGAAGG';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);