#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)www.linkedin.com/in/(?P<linkedin>[^/\Z\n]+)"
Local $sString = "https:/www.linkedin.com/in/djeffersonx" & @CRLF & _
"https://www.linkedin.com/in/lealfelipealves" & @CRLF & _
"https:/www.linkedin.com/in/djeffersonx" & @CRLF & _
"https://www.linkedin.com/in/alex-augusto-083934138/?locale=en_US" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")