$re = '/www.linkedin.com/in/(?P<linkedin>[^/\Z\n]+)/m';
$str = 'https:/www.linkedin.com/in/djeffersonx
https://www.linkedin.com/in/lealfelipealves
https:/www.linkedin.com/in/djeffersonx
https://www.linkedin.com/in/alex-augusto-083934138/?locale=en_US
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);