import Foundation
let pattern = #"www.linkedin.com/in/(?P<linkedin>[^/\Z\n]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https:/www.linkedin.com/in/djeffersonx
https://www.linkedin.com/in/lealfelipealves
https:/www.linkedin.com/in/djeffersonx
https://www.linkedin.com/in/alex-augusto-083934138/?locale=en_US
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)