// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)www.linkedin.com/in/(?P<linkedin>[^/\Z\n]+)").unwrap();
let string = "https:/www.linkedin.com/in/djeffersonx
https://www.linkedin.com/in/lealfelipealves
https:/www.linkedin.com/in/djeffersonx
https://www.linkedin.com/in/alex-augusto-083934138/?locale=en_US
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}