using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\n]*)(\n|$)";
string substitution = @".$1$2";
string input = @"This is my first line
This is my second line
This is my third line";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}