$re = '/([^\n]*)(\n|$)/';
$str = 'This is my first line
This is my second line
This is my third line';
$subst = ".$1$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;