use strict;
my $str = 'This is my first line
This is my second line
This is my third line';
my $regex = qr/([^\n]*)(\n|$)/p;
my $subst = '.$1$2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";