const regex = /([^\n]*)(\n|$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\n]*)(\\n|$)', '')
const str = `This is my first line
This is my second line
This is my third line`;
const subst = `.$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);