#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^((http(s)?):\/\/)?(www.)?([\da-zA-z\_\-]+)\.(com|(|[\da-zA-Z]{2,6}))([\/\w \.\-\#\&\?\%\_]*)?([^\/| |\s])$"
Local $sString = "https://www.test.com/ " & @CRLF & _
"https://www.test.com/" & @CRLF & _
"https://test.com/ " & @CRLF & _
"https://test.com" & @CRLF & _
"https://www.test.com/ " & @CRLF & _
"https://www.test.com/directory/" & @CRLF & _
"https://www.test.com/directory/ " & @CRLF & _
"https://www.test.com/directory/directory/" & @CRLF & _
"https://www.test.com/directory/directory/ " & @CRLF & _
"www.test.net/" & @CRLF & _
"http://www.test.net/ " & @CRLF & _
"https://www.test.net/ " & @CRLF & _
"https://www.test.net/directory/" & @CRLF & _
"https://www.test.net/directory/directory/directory" & @CRLF & _
"test.org/ " & @CRLF & _
"www.test.net" & @CRLF & _
"www.test.gov" & @CRLF & _
"www.test.gov/" & @CRLF & _
"test.gov/" & @CRLF & _
"www.test.org" & @CRLF & _
"www.test.com/ " & @CRLF & _
"http://www.test.com/" & @CRLF & _
"https://www.test.com/directory/news-events/index.html?date=2013-05-01" & @CRLF & _
"https://test.test.com/directory/news-events/index.html?date=2013-07-07"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")