import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((http(s)?):\\/\\/)?(www.)?([\\da-zA-z\\_\\-]+)\\.(com|(|[\\da-zA-Z]{2,6}))([\\/\\w \\.\\-\\#\\&\\?\\%\\_]*)?([^\\/| |\\s])$";
final String string = "https://www.test.com/ \n"
+ "https://www.test.com/\n"
+ "https://test.com/ \n"
+ "https://test.com\n"
+ "https://www.test.com/ \n"
+ "https://www.test.com/directory/\n"
+ "https://www.test.com/directory/ \n"
+ "https://www.test.com/directory/directory/\n"
+ "https://www.test.com/directory/directory/ \n"
+ "www.test.net/\n"
+ "http://www.test.net/ \n"
+ "https://www.test.net/ \n"
+ "https://www.test.net/directory/\n"
+ "https://www.test.net/directory/directory/directory\n"
+ "test.org/ \n"
+ "www.test.net\n"
+ "www.test.gov\n"
+ "www.test.gov/\n"
+ "test.gov/\n"
+ "www.test.org\n"
+ "www.test.com/ \n"
+ "http://www.test.com/\n"
+ "https://www.test.com/directory/news-events/index.html?date=2013-05-01\n"
+ "https://test.test.com/directory/news-events/index.html?date=2013-07-07";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}