#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]*\.?[0-9]+$"
Local $sString = ".1" & @CRLF & _
"1.10" & @CRLF & _
"1231313" & @CRLF & _
"0.32131" & @CRLF & _
"31313113.123123123" & @CRLF & _
"" & @CRLF & _
"0.1.1.1" & @CRLF & _
"dadadd.31232 " & @CRLF & _
"12313jn123 " & @CRLF & _
"dshiodah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")