// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]*\.?[0-9]+$").unwrap();
let string = ".1
1.10
1231313
0.32131
31313113.123123123
0.1.1.1
dadadd.31232
12313jn123
dshiodah";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}