using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9]*\.?[0-9]+$";
string input = @".1
1.10
1231313
0.32131
31313113.123123123
0.1.1.1
dadadd.31232
12313jn123
dshiodah";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}