package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]*\.?[0-9]+$`)
var str = `.1
1.10
1231313
0.32131
31313113.123123123
0.1.1.1
dadadd.31232
12313jn123
dshiodah`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}