package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<SharedDataSetReference>([^\/]+)<\/SharedDataSetReference>`)
var str = `<SharedDataSetReference>Company</SharedDataSetReference>
<SharedDataSetReference>Customer</SharedDataSetReference>
<SharedDataSetReference>/DataSets/AnyDataSetName</SharedDataSetReference>
<SharedDataSetReference>AnyDataSetName</SharedDataSetReference>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}