re = /<SharedDataSetReference>([^\/]+)<\/SharedDataSetReference>/m
str = '<SharedDataSetReference>Company</SharedDataSetReference>
<SharedDataSetReference>Customer</SharedDataSetReference>
<SharedDataSetReference>/DataSets/AnyDataSetName</SharedDataSetReference>
<SharedDataSetReference>AnyDataSetName</SharedDataSetReference>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end