$re = '/<SharedDataSetReference>([^\/]+)<\/SharedDataSetReference>/m';
$str = '<SharedDataSetReference>Company</SharedDataSetReference>
<SharedDataSetReference>Customer</SharedDataSetReference>
<SharedDataSetReference>/DataSets/AnyDataSetName</SharedDataSetReference>
<SharedDataSetReference>AnyDataSetName</SharedDataSetReference>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);